I’m receiving a #1074 – Too big column length for column … when installing GMaps

It has been reported of a few users of GMaps that they have been receiving a 1074 error when installing the component.  This apparently is caused when using an older 4.x version of MySQL.  Older versions of MySQL did not support VARCHAR datatypes greater than 255 in size.

GMaps was developed on a PHP 5 and MySQL 5 environment; however, additional testing was done on PHP 4 and MySQL 4.4 version without any problem.

If you can upgrade your database, great.  I will create a fix for this and an update path who already installed GMaps and have it operational.

You may also like